如何在 eclipse 3.3 中使用 junit4

因為工作需到的關係,會用到 eclipse 3.3 版。最近在用 junit4,沒想到 eclipse 預設是用 junit3。

要改用 junit4,要手動打開 project 的 properties 設定,移除 juni3 library,加入 junit library (選擇 version4)。

在舊的 test case,需要繼承 TestCase 類別,但是在 juni4 不用再繼承 TestCase,只要在測試的方法上加入 @Test 宣告就可以了,另外,要記得 import static org.junit.Assert.*,才可以做測試。

junit runnner 部分,要用 Run as dialog,打開視窗,選擇用 version 4 的 runner。

其他的部分,可以參考 JUnit 4 in 60 Seconds 這篇文章。

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com Logo

你正使用 WordPress.com 帳號留言。 登出 / 變更 )

Twitter picture

你正使用 Twitter 帳號留言。 登出 / 變更 )

Facebook照片

你正使用 Facebook 帳號留言。 登出 / 變更 )

Google+ photo

你正使用 Google+ 帳號留言。 登出 / 變更 )

連結到 %s

%d 位部落客按了讚: