gentoo linux – dev-lang/php 的發展進入穩定期

之前 gentoo linux 上要安裝 php、mod_php 都是使用 dev-php/php、dev-php/mod_php 套件,在 gentoo linux 的 portage 環境中,php5 一直沒有被 mark 為 stable 的套件,主要的原因是 php5 和 php4 不是完全相容的,有一些舊的 php 程式還是要使用 php4 才可以正常的運作,但是就之前的 portagte 架構,沒有辦法在同一台電腦上同時讓 php4、php5 共存,所以才會試著更改 php 在 portage 中的架構,成為 dev-lang/php。

為了處理 php4、php5 共存的問題,gentoo linux 的發展者決定把 php 的 portage 改到 dev-lang/php 之下,另外再增加了 dev-php4、dev-php5 這 2 個目錄,把 php4 php5 所使用到的套件分開來處理。

相關文件:
1.Upgrading PHP
2.Configure Apache to work with PHP4 and PHP5
3.Upgrading Apache

Advertisements

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com Logo

您的留言將使用 WordPress.com 帳號。 登出 / 變更 )

Twitter picture

您的留言將使用 Twitter 帳號。 登出 / 變更 )

Facebook照片

您的留言將使用 Facebook 帳號。 登出 / 變更 )

Google+ photo

您的留言將使用 Google+ 帳號。 登出 / 變更 )

連結到 %s

%d 位部落客按了讚: